ANNOUNCEMENT: Show your interest in a RPGAIO Live Stream Q & A Event! Click Here!

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Switch API Compatibility Level to .NET 2.0
#1
Hi,

Currently, as we use Newtonsoft.JSON for saving and loading, you will need to change to using the full .NET 2.0 Api Compatibility Level rather than just using the  .NET 2.0 subset.

Issues: 
  • May prevent game data from loading correctly
  • May break the game in a build only version
  • Prevents build succeeding when building for Mobile OS's
Fix :
To switch from the subset to full .NET 2.0 first go to Edit > Project Settings > Player in the Unity Editor. 

Then scroll down to the configuration section and change the API Compatibility Level to .NET 2.0.

[Image: xBdM8Ai.png]


Forum Jump:


Users browsing this thread: 1 Guest(s)