ANNOUNCEMENT: Show your interest in a RPGAIO Live Stream Q & A Event! Click Here!

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update 1.5.2 - Live
#11
That's all I needed to hear.
Reply
#12
Smile 
(04-28-2018, 12:23 PM)logicspawn Wrote:
(04-15-2018, 08:47 PM)Vallhal Wrote: I just want to know if everything is planned and will version 2.0 be released by the end of April? Thank you
And if it was not possible to add 2 different walks. For example 1- for normal walking and 2- when I press F = walk with sword OR walk with torch

(04-27-2018, 03:23 PM)redmondking Wrote: When is the tutorials on 1.5.2 going on YouTube? And the end of April is almost here any news on update 2.0.0?

(04-27-2018, 07:33 PM)williamian Wrote:
(04-27-2018, 03:23 PM)redmondking Wrote: When is the tutorials on 1.5.2 going on YouTube? And the end of April is almost here any news on update 2.0.0?

He was on a roll with updates and info. That was my question as well.

Apologies! I got sidetracked working on 2.0 and forget to finish that tutorial. I'll get that up at the start of next week.

In regards to 2.0, we are still working on this as fast as we can, it is a huge update and there is a lot to do, while we hoped to have it out at the end of April that is not a possibility at the moment and once we have a new ETA I will post an announcement accordingly.

Apologies for the delay, and thank you for your patience, I can ensure that once 2.0 it will be worth that wait! (Something unannounced until now is that we will likely have new demo scenes and assets [actual models] to showcase RPGAIO's capabilities out of the box!)


Looking very forward to V 2, sounds very exciting !!!  :-)
Reply
#13
So far I have been thoroughly enjoying this product (it's nice spending time on the mechanics and design without needing to rewrite the wheel every time) and for the first time since buying it in November of last year, I'm running into an issue.

(Probably my fault)

I recently updated a project from Unity 2017.1.1 to 2017.3.1 and started running into weird issues after running my first scene. Here's my set up:

Created a single race/sub-race/class and the matching character used the "skip character creation" option (as my current game just has a single character). I've set up the character and added a single skill and assigned it to be part of the class I created. But now when starting up I'm getting a slew of these errors (replaced paths for various reasons):
Code:
NullReferenceException: Object reference not set to an instance of an object
 at RPG_Camera.GetCameraPosition (Single xAxis, Single yAxis, Single distance) [0x00019] in [path to directory]
 at RPG_Camera.GetDesiredPosition () [0x00021] in [path to directory]
 at RPG_Camera.FixedUpdate () [0x0006e] in [path to directory]

(Filename: Assets/RPGAIO/Scripts/Beta/MovementAndCamera/RPG_Camera.cs Line: 452)

NullReferenceException: Object reference not set to an instance of an object
 at SkillBarButtonModel.Update () [0x0000e] in [path to directory]

(Filename: Assets/RPGAIO/UI/UIModels/SkillBarButtonModel.cs Line: 22)

NullReferenceException: Object reference not set to an instance of an object
 at PetUI.Update () [0x00001] in [path to directory]

(Filename: Assets/RPGAIO/UI/PetUI.cs Line: 32)

NullReferenceException: Object reference not set to an instance of an object
 at InventoryUI.Update () [0x00007] in [path to directory]

(Filename: Assets/RPGAIO/UI/InventoryUI.cs Line: 45)

NullReferenceException: Object reference not set to an instance of an object
 at CharacterTexturePreviewModel.Update () [0x0000c] in [path to directory]

(Filename: Assets/RPGAIO/UI/UIModels/CharacterTexturePreviewModel.cs Line: 16)

NullReferenceException: Object reference not set to an instance of an object
 at SkillBarButtonModel.Update () [0x0000e] in [path to directory]

(Filename: Assets/RPGAIO/UI/UIModels/SkillBarButtonModel.cs Line: 22)

NullReferenceException: Object reference not set to an instance of an object
 at SkillBarButtonModel.Update () [0x0000e] in [path to directory]

(Filename: Assets/RPGAIO/UI/UIModels/SkillBarButtonModel.cs Line: 22)

NullReferenceException: Object reference not set to an instance of an object
 at VendorUI.Update () [0x00007] in [path to directory]

(Filename: Assets/RPGAIO/UI/VendorUI.cs Line: 98)

NullReferenceException: Object reference not set to an instance of an object
 at SkillBarButtonModel.Update () [0x0000e] in [path to directory]

(Filename: Assets/RPGAIO/UI/UIModels/SkillBarButtonModel.cs Line: 22)

NullReferenceException: Object reference not set to an instance of an object
 at SkillBarButtonModel.Update () [0x0000e] in [path to directory]

(Filename: Assets/RPGAIO/UI/UIModels/SkillBarButtonModel.cs Line: 22)

NullReferenceException: Object reference not set to an instance of an object
 at QuestHandler.CheckItemConditionState () [0x00001] in [path to directory]
 at QuestHandler.Update () [0x00002] in [path to directory]




(Filename: Assets/RPGAIO/Scripts/Core/Questing/QuestHandler.cs Line: 209)


Any ideas jump out at you? I can't seem to figure this out; I haven't set up any quests yet and I think I filled out the skill all the way

Here's a screenshot of the skill:
[Image: ghh3ivp.png]



Thanks for all of the hard work you pour into this asset! Super excited about V2.0!
Reply
#14
(05-01-2018, 04:01 AM)ArneSaknussemm Wrote: So far I have been thoroughly enjoying this product (it's nice spending time on the mechanics and design without needing to rewrite the wheel every time) and for the first time since buying it in November of last year, I'm running into an issue

It may just be to do with the fact you added some new skills/quests, try run character creation again and make a new character so it has the updated quest / skill data.
Reply
#15
(05-01-2018, 06:50 AM)logicspawn Wrote:
(05-01-2018, 04:01 AM)ArneSaknussemm Wrote: So far I have been thoroughly enjoying this product (it's nice spending time on the mechanics and design without needing to rewrite the wheel every time) and for the first time since buying it in November of last year, I'm running into an issue

It may just be to do with the fact you added some new skills/quests, try run character creation again and make a new character so it has the updated quest / skill data.

So how would a character already created get newly created skills/quests?
Reply
#16
(05-01-2018, 06:50 AM)logicspawn Wrote:
(05-01-2018, 04:01 AM)ArneSaknussemm Wrote: So far I have been thoroughly enjoying this product (it's nice spending time on the mechanics and design without needing to rewrite the wheel every time) and for the first time since buying it in November of last year, I'm running into an issue

It may just be to do with the fact you added some new skills/quests, try run character creation again and make a new character so it has the updated quest / skill data.

So I'm still running into this issue. Luckily it was just the beginning of setting things up, so I actually started over from scratch. But now I can't seem to get it to work at all.

All I've done is create the races/sub-races and then created a Character with the single class I made. I generated the prefab and updated it to use the correct model. Cloned the Mecanim controller and assigned animations. Then set up the RPG Controller script to use the correct model on the prefab.

I've verified that the child model has no tags and it's stripped of all components except for Transforms and and the Animator. But when starting a scene with the character, I get thousands of  "Object reference not set to an instance of an object" from various scripts: PetUI, Inventory, SkillBarButton Model, etc etc).

Not running into these issues on another game I've been working on following the exact same steps.

I even went back through and followed your tutorial from the beginning on setting up characters. Kinda stuck at this point.

EDIT: Turns out the layers had gotten all wonky somehow. Reimported project settings and then was able to add the character to the "Combatant" layer and it's all happy now.
Reply
#17
(05-14-2018, 04:34 AM)ArneSaknussemm Wrote:
(05-01-2018, 06:50 AM)logicspawn Wrote:
(05-01-2018, 04:01 AM)ArneSaknussemm Wrote: So far I have been thoroughly enjoying this product (it's nice spending time on the mechanics and design without needing to rewrite the wheel every time) and for the first time since buying it in November of last year, I'm running into an issue

It may just be to do with the fact you added some new skills/quests, try run character creation again and make a new character so it has the updated quest / skill data.

So I'm still running into this issue. Luckily it was just the beginning of setting things up, so I actually started over from scratch. But now I can't seem to get it to work at all.

All I've done is create the races/sub-races and then created a Character with the single class I made. I generated the prefab and updated it to use the correct model. Cloned the Mecanim controller and assigned animations. Then set up the RPG Controller script to use the correct model on the prefab.

I've verified that the child model has no tags and it's stripped of all components except for Transforms and and the Animator. But when starting a scene with the character, I get thousands of  "Object reference not set to an instance of an object" from various scripts: PetUI, Inventory, SkillBarButton Model, etc etc).

Not running into these issues on another game I've been working on following the exact same steps.

I even went back through and followed your tutorial from the beginning on setting up characters. Kinda stuck at this point.

EDIT: Turns out the layers had gotten all wonky somehow. Reimported project settings and then was able to add the character to the "Combatant" layer and it's all happy now.

If you have any more issues please create a thread in the questions/queries section and I'll help you out.

In response to how characters will get newly created skills/quests, in RPGAIO 2.0 this will just be done automatically. If the player's quests/skills do not match the ones in the game data, they will be added/removed appropriately.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)